Back to overview
Degraded

Slowness observed in background jobs

Oct 31 at 04:52am PDT
Affected services
Background Jobs Latency
Email Sending Latency
Email Request Fulfillment Latency
Mobile Number Fulfillment Latency

Resolved
Oct 31 at 06:30am PDT

The issue is resolved now

Updated
Oct 31 at 06:15am PDT

The issue impacting asynchronous job processing in Apollo has been mitigated.
We’re now seeing steady improvement in the processing of waterfall-related enrichments and other dependent async workflows.

Our teams will continue to monitor the system closely to ensure full recovery and stable performance.

Thank you for your patience while we worked through this issue.

Updated
Oct 31 at 05:48am PDT

We've made progress in restoring several impacted services in Apollo.
Mobile and email fulfillment, AI Powerups, and Sequences are starting to recover and are functioning for most users.

However, we're still experiencing issues with waterfall-related enrichments, which may cause delays or incomplete enrichment data.

Our engineering team is actively working on resolving the remaining issues and monitoring the system for stability.
We'll continue to provide updates as we make further progress.

Thank you for your continued patience and understanding.

Created
Oct 31 at 04:52am PDT

We're currently investigating an issue in Apollo that's affecting asynchronous job processing across multiple systems.

🔍 Impacted Areas

Mobile and email fulfillment: Delays or failures in message delivery.

Data indexing: Search results may show outdated data due to indexing delays.

AI Powerups: Certain AI features may not trigger or complete as expected.

Sequences: Step executions and follow-ups may be delayed.

Our engineering team is actively working to identify the root cause and restore normal functionality.

We'll continue to share updates as we make progress.
Thank you for your patience and understanding.