Back to overview
Resolved
Salesforce Service Disruption
Sep 16, 2026 at 11:00am UTC
Affected services
app.apollo.io
Resolved
Sep 16, 2026 at 11:00am UTC
Salesforce instances are currently has service disruption. This may impact Salesforce-related functionality and integrations.
We’re monitoring the situation and will provide another update once the instances are back online.
Affected services