Back to overview
Downtime
Apollo sites are unreachable
Jul 24 at 07:28am PDT
Affected services
app.apollo.io
www.apollo.io
Resolved
Jul 24 at 08:09am PDT
Issue with the marketing website has been resolved
Affected services
www.apollo.io
Updated
Jul 24 at 07:39am PDT
Issue with the Apollo app is resolved
Affected services
app.apollo.io
www.apollo.io
Created
Jul 24 at 07:28am PDT
At 14:28 GMT Our Security Team was testing a bot detection mechanism and the outcome of that led to blocking some normal/good users.
Affected services
app.apollo.io
www.apollo.io