Back to overview
Downtime
Site was briefly unavailable
Aug 29 at 03:12am PDT
Affected services
app.apollo.io
Resolved
Aug 29 at 03:17am PDT
The issue was remediated 3:17am PST.
Affected services
app.apollo.io
Created
Aug 29 at 03:12am PDT
Apollo app was briefly unavailable from 3:14am PST due to a database issue. We are investigating the root cause
Affected services
app.apollo.io