Back to overview
Downtime
app.apollo.io shows an infinite loading wheel
Feb 24 at 01:17pm PST
Affected services
app.apollo.io
Resolved
Feb 24 at 01:42pm PST
We identified a manual error that brought down the site, and fixed the issue
Affected services
app.apollo.io
Created
Feb 24 at 01:17pm PST
Some pages on app.apollo.io show an infinite loading wheel
Affected services
app.apollo.io