Back to overview
Degraded
Email Delays
Apr 04 at 01:47am PDT
Affected services
Background Jobs Latency
Email Sending Latency
Resolved
Apr 04 at 03:25am PDT
The fix was rolled out to all users and all functionality should be operational.
Affected services
Background Jobs Latency
Email Sending Latency
Updated
Apr 04 at 03:15am PDT
Fix has been deployed and is propagating through the deployment fleet.
Affected services
Background Jobs Latency
Email Sending Latency
Created
Apr 04 at 01:47am PDT
Sending email and syncing replies on Microsoft Office365 & Outlook mailboxes delayed. New email accounts may not link.
Affected services
Background Jobs Latency
Email Sending Latency