Back to overview
Email signups temporarily unavailable
May 22 at 11:51am PDT
Affected services
www.apollo.io
Resolved
May 22 at 01:41pm PDT
Signups are working again.
Affected services
www.apollo.io
Created
May 22 at 11:51am PDT
An attempt to sign up using email resulted in an internal error.
Affected services
www.apollo.io