Back to overview
Degraded

app.apollo.io - slowness observed during bulk selecting contacts in Prospecting

Jun 09 at 11:20pm PDT
Affected services
app.apollo.io

Resolved
Jun 10 at 12:49am PDT

We have resolved the root cause for this issue. Thanks for your patience!

Created
Jun 09 at 11:20pm PDT

Few users are observing issues in selecting large number of contacts in Prospecting page. We're working on fixing the issue