Global GCP Outage
Resolved
Jun 12 at 05:30pm PDT
The upstream issue has been marked as resolved by our Cloud Provider. All of our systems are reporting fine.
Affected services
app.apollo.io
www.apollo.io
Background Jobs Latency
Email Sending Latency
Email Request Fulfillment Latency
Mobile Number Fulfillment Latency
Payment Gateway
Created
Jun 12 at 12:04pm PDT
Apollo is experiencing technical issues with the Google Cloud Provider. Some features, such as meetings, conversations intelligence, and Gmail authentication, are experiencing failures.
Affected services
app.apollo.io
www.apollo.io
Background Jobs Latency
Email Sending Latency
Email Request Fulfillment Latency
Mobile Number Fulfillment Latency
Payment Gateway