Performance Degradation: some users experienced delays due to database performance degradation. Mobile number fulfillment was delayed for the duration of the incident.
Resolved
Jul 23 at 10:42am PDT
The fulfillment has been processed and operating normally
Affected services
app.apollo.io
Mobile Number Fulfillment Latency
Updated
Jul 23 at 10:36am PDT
Mobile Number Fulfillment is running again and processing the queue
Affected services
app.apollo.io
Mobile Number Fulfillment Latency
Updated
Jul 23 at 10:17am PDT
Mobile number Fulfillment is on hold, we're investigating options for re-enabling it.
Affected services
app.apollo.io
Mobile Number Fulfillment Latency
Updated
Jul 23 at 09:00am PDT
Degraded nodes have been repaired. Site is operating normally now, we continue to monitor performance closely.
Affected services
app.apollo.io
Updated
Jul 23 at 08:23am PDT
Investigation is still ongoing
Affected services
app.apollo.io
Created
Jul 23 at 07:50am PDT
Application is slow due to database performance degradation.
Affected services
app.apollo.io