Back to overview

apollo.io - website facing slowness

Aug 03 at 11:52pm PDT
Affected services
app.apollo.io
Background Jobs Latency

Resolved
Aug 04 at 12:50am PDT

We have identified the root cause and issue has been resolved.

Created
Aug 03 at 11:52pm PDT

We have detected slowness in few of our API’s. We’re working of fixing the issue and site should be back soon.