Back to overview
Downtime

Background Jobs Delayed

Sep 18 at 07:05am PDT
Affected services
Background Jobs Latency
Email Sending Latency
Email Request Fulfillment Latency
Mobile Number Fulfillment Latency

Resolved
Sep 18 at 07:41am PDT

We have identified and mitigated the impact. All systems are back to normal.

Created
Sep 18 at 07:05am PDT

We faced an infrastructure level issue impacting all our background jobs. Our team is investigating it.