Back to overview
Downtime

Mobile enrichment delayed

Sep 30, 2025 at 11:08am UTC
Affected services
Mobile Number Fulfillment Latency

Resolved
Sep 30, 2025 at 2:23pm UTC

Jobs have been processed and site is operating normally again

Updated
Sep 30, 2025 at 1:32pm UTC

Enrichments are processed at a degraded capacity

Created
Sep 30, 2025 at 11:08am UTC

Mobile enrichment is delayed to customers