Back to overview
Degraded

Microsoft mailbox linking failures

Sep 30 at 04:50pm PDT
Affected services
app.apollo.io
Email Sending Latency

Resolved
Oct 01 at 01:49am PDT

Errors seems to be resolved now. Thanks for your patience!

Updated
Oct 01 at 01:23am PDT

Our internal monitoring shows errors have reduced. However there is still few errors and microsoft is still mitigating the incident: https://status.cloud.microsoft/m365/referrer=serviceStatusRedirect

We expect this to be fully resolved in some time.

Created
Sep 30 at 04:50pm PDT

We experienced an issue with Microsoft services that impacted mailbox linking in Apollo. During this time, users attempting to connect Outlook or Microsoft 365 mailboxes may have encountered errors, and some customers may also have experienced delays in email sending. This is due to a Microsoft outage and is now being resolved by Microsoft.