Back to overview
Downtime
app.apollo.io - website not loading / slow
Nov 13 at 01:36am PST
Affected services
app.apollo.io
Background Jobs Latency
Email Sending Latency
Email Request Fulfillment Latency
Mobile Number Fulfillment Latency
Payment Gateway
Resolved
Nov 13 at 02:15am PST
We have identified the root cause of the issue and issue has been resolved.
Affected services
Created
Nov 13 at 01:36am PST
We have detected high latency on loading our application. We're working on fixing the issue and site should be back again very soon.
Affected services