Back to overview
Degraded
Website Impacted - Vendor Outage (Cloudflare)
Nov 18 at 05:00am PST
Affected services
app.apollo.io
Resolved
Nov 18 at 06:52am PST
Vendor has reported a fix has been deployed.
Our systems are working as expected now. We are continuing to monitor for some more time.
Affected services
Created
Nov 18 at 05:00am PST
We have identified impact to our app due to the global outage reported by our vendor - Cloudflare - https://www.cloudflarestatus.com/incidents/8gmgl950y3h7.
We are continuously monitoring and will be updating here once we have more information.
Affected services