Back to overview
Downtime

Website Impacted - Vendor Outage (Cloudflare)

Dec 05 at 01:00am PST
Affected services
app.apollo.io
www.apollo.io
Background Jobs Latency
Email Sending Latency
Email Request Fulfillment Latency
Mobile Number Fulfillment Latency
Payment Gateway

Resolved
Dec 05 at 01:20am PST

Vendor has reported a fix has been deployed.
Our systems are working as expected now. We are continuing to monitor for some more time.

Created
Dec 05 at 01:00am PST

Scheduled maintenance is currently in progress by Cloudflare that affected Apollo app for the regions that are non operational on their end.
https://www.cloudflarestatus.com/