Back to overview
Degraded
Increased latency on the website
Dec 31 at 09:07am PST
Affected services
app.apollo.io
Resolved
Dec 31 at 09:20am PST
We have identified the root cause and mitigated the impact.
Affected services
Created
Dec 31 at 09:07am PST
Website is experiencing latency on the database since last 30 minutes.
Affected services