Issues with emails on Apollo
Resolved
Jan 13 at 11:25am PST
The issue has been mitigated.
Affected services
Updated
Jan 13 at 11:10am PST
The team has identified the root cause and is currently implementing a solution.
Affected services
Updated
Jan 13 at 10:24am PST
The team's investigation is ongoing in parallel with a mitigation effort.
Affected services
Updated
Jan 13 at 09:36am PST
The team is continuing to investigate the root cause of the issue.
Affected services
Updated
Jan 13 at 08:55am PST
We are continuing to investigate the issue and working on a mitigation.
Affected services
Updated
Jan 13 at 08:25am PST
We are still in the process of identifying the root cause
Affected services
Created
Jan 13 at 07:19am PST
We are investigating an issue with increased latency for emails on Apollo.
Affected services