Back to overview
Degraded

Password-reset flow is non-functional

Mar 23, 2026 at 07:37am UTC
Affected services
app.apollo.io

Resolved
Mar 23, 2026 at 03:23pm UTC

We have identified and resolved the issue with our password-reset flow.

Created
Mar 23, 2026 at 07:37am UTC

We are investigating issues with our password-reset flow