Email related functionality is degraded
Resolved
Mar 31, 2026 at 04:03pm UTC
Status: Resolved
We identified and mitigated a database infrastructure issue that impacted some email-related Apollo features. Service has been restored, and latency has returned to normal levels.
Customers may have experienced delays or degraded performance in affected email-related workflows during the incident window. We will continue to monitor the system closely.
Affected services
Updated
Mar 31, 2026 at 03:48pm UTC
Status: Monitoring
We identified an issue in the database infrastructure supporting some email-related Apollo features, which caused degraded performance and delays for affected workflows. A mitigation has been applied and the impacted cluster is back up.
Customers may have experienced slower processing or intermittent issues in email-related features during this period. We are monitoring recovery closely to ensure performance returns fully to normal.
Affected services
Updated
Mar 31, 2026 at 03:40pm UTC
We are currently investigating elevated latency in our email-related infrastructure. As a result, some Apollo features that rely on email processing may be delayed or degraded for customers.
Affected services
Created
Mar 31, 2026 at 03:20pm UTC
We are observing degradation related to email functionality. Customers will be impacted due to high latency on functionality related to Email
Affected services