Apollo Web App Degraded Performance
Resolved
Apr 15, 2026 at 5:19pm UTC
Site is fully restored.
Affected services
Updated
Apr 15, 2026 at 4:15pm UTC
Performance continues to improve and we monitor closely. Site should be available across all regions now.
Affected services
Updated
Apr 15, 2026 at 3:43pm UTC
The Apollo web app has largely recovered, but we are still observing region-specific degradation affecting a subset of users. Our team is actively investigating the impacted regions and monitoring performance closely.
Affected services
Updated
Apr 15, 2026 at 3:31pm UTC
We implemented a mitigation and the Apollo web app is now operating normally. Performance and availability metrics have remained healthy for the past 15 minutes, and we are continuing to monitor closely.
Affected services
Created
Apr 15, 2026 at 3:09pm UTC
We are currently investigating degraded performance in the Apollo web app. Some users may be experiencing loading issues. We will provide updates as more information becomes available.
Affected services