Back to overview
Degraded

Degraded performance for Mixed Enrichment API

Apr 17, 2026 at 1:06pm UTC
Affected services
app.apollo.io
www.apollo.io
Background Jobs Latency
Email Sending Latency
Email Request Fulfillment Latency
Mobile Number Fulfillment Latency
Payment Gateway

Resolved
Apr 17, 2026 at 6:23pm UTC

This is mitigated now

Updated
Apr 17, 2026 at 2:59pm UTC

We’ve implemented a fix for the issue affecting the Mixed Enrichment API and are currently rolling it out to production. A small subset of users may continue to experience delayed enrichments while the rollout is in progress. Once the deployment is complete, we’ll monitor the service closely to confirm the issue is fully resolved.

Created
Apr 17, 2026 at 1:06pm UTC

We’ve identified an issue affecting the Mixed Enrichment API. A small subset of users may experience delayed enrichments at this time. Our team is actively working on a fix and we’ll share another update as soon as we have more information.