Back to overview
Degraded

Email enrichment requests are currently experiencing delays

May 5, 2026 at 7:20am UTC
Affected services
Email Request Fulfillment Latency

Resolved
May 5, 2026 at 8:50am UTC

Earlier degraded performance with email enrichment was caused by unscheduled maintenance from an upstream vendor, which has since been resolved. Email enrichment requests are now processing normally, and any jobs that failed during the window will be automatically retried and completed.

Created
May 5, 2026 at 7:20am UTC

We're currently experiencing degraded performance with email enrichment requests. Some users may notice delays in email-finding results and longer processing times for background jobs.

Other Apollo functionality remains unaffected. Our engineering team has identified the issue and is actively working on a resolution. Affected jobs will automatically retry and complete once service is restored, no action is required from users.