Back to overview
Degraded

Degraded Performance

May 5, 2026 at 2:34pm UTC
Affected services
app.apollo.io

Resolved
May 5, 2026 at 3:56pm UTC

The issue is now resolved

Updated
May 5, 2026 at 3:29pm UTC

We've identified a mitigation, rolled it out, and are seeing improvements. The team is continuing to monitor.

Created
May 5, 2026 at 2:34pm UTC

We are currently investigating reports of degraded performance affecting some users, including slower page load times across the Apollo platform. Our engineering team is actively looking into the issue to identify the root cause.