Back to overview
Degraded
Apollo Web App Degraded Performance
May 6, 2026 at 1:10pm UTC
Affected services
app.apollo.io
Resolved
May 6, 2026 at 2:35pm UTC
The issue is now resolved. Our engineering team continues to monitor all services.
Affected services
Created
May 6, 2026 at 1:10pm UTC
We are currently investigating degraded performance in the Apollo web app. We will provide updates as more information becomes available
Affected services