Back to overview
Degraded
Degraded Performance on Apollo
May 6, 2026 at 7:43pm UTC
Affected services
app.apollo.io
Resolved
May 6, 2026 at 7:59pm UTC
The issue has been resolved
Affected services
Created
May 6, 2026 at 7:43pm UTC
We are currently investigating reports of degraded performance. Our engineering team is actively looking into the issue to identify the root cause.
Affected services