Search and queue degradation
Resolved
May 12, 2026 at 7:25pm UTC
The issue has been resolved and all products should be operating normally.
Affected services
Updated
May 12, 2026 at 6:30pm UTC
We have stabilized the cluster and queues are catching up. Latency is starting to stabilize.
Affected services
Created
May 12, 2026 at 3:10pm UTC
Our queue infrastructure is degraded. Data changes may take longer time to propagate, and sequences take longer time to run.
Affected services