Back to overview
Resolved

Processing Delays

Jul 7, 2026 at 7:45pm UTC
Affected services
Background Jobs Latency

Resolved
Jul 7, 2026 at 8:29pm UTC

A mitigation has been rolled out and processing times are recovering. Recent updates are appearing normally and the earlier backlog is catching up. We are continuing to monitor.

Created
Jul 7, 2026 at 7:45pm UTC

We've received reports that some customers are experiencing delays processing recent updates. CSV uploads, contacts added to lists or sequences, and recent activity such as emails, tasks, and calls may be slow to appear in search and analytics. We're investigating and will provide updates as we learn more.