Back to overview
Resolved

Processing Delays

Aug 3, 2026 at 4:38pm UTC
Affected services
Background Jobs Latency

Resolved
Aug 3, 2026 at 5:54pm UTC

A mitigation has been rolled out and processing times have recovered. Recent updates are appearing normally and the earlier backlog is catching up. We are continuing to monitor.

Created
Aug 3, 2026 at 4:38pm UTC

We’ve received reports that some customers are experiencing delays processing CSV uploads. Uploads are being accepted and no files are lost, but results may take longer than usual to appear while we work through the backlog. We’re investigating and will provide updates as we learn more.