Investigating — Slow performance across Apollo
Resolved
Aug 7, 2026 at 12:51pm UTC
Resolved - Slow performance across Apollo
This incident has been resolved. All services are fully restored and performance is back to normal.
The slowdown was caused by an issue with our CDN provider, which has since been resolved.
We apologize for any disruption and thank you for your patience.
Affected services
Updated
Aug 7, 2026 at 12:47pm UTC
Services are back up, but performance is still degraded while we work on a full recovery. You may continue to see slower load times in the meantime. We're actively working to bring everything back to normal and will post another update shortly.
Affected services
Created
Aug 7, 2026 at 12:33pm UTC
We're seeing slower than normal load times across the app and are actively investigating. You may notice pages taking longer to load or searches responding slowly. No data is affected.
Affected services